EXCEL: TIPS AND TRICKS
Academic Resources Conference

August 15, 2019
WSU Microsoft Office Training
For a full listing of training sessions on Microsoft Office products, visit myTraining in myWSU.

myTraining For Employees: Instructor Led, Online & Materials
## CONTENTS

CONTENTS................................................................................................................................................... 2

EXCEL NAVIGATION..................................................................................................................................... 3
  NAVIGATION OPTIONS.................................................................................................................................. 3

FLASH FILL.................................................................................................................................................. 4
  Recognizing Patterns............................................................................................................................ 4
  Flash Fill to Combine Cells ................................................................................................................... 5

FIND AND REPLACE................................................................................................................................... 7

SORTING AND FILTERING ......................................................................................................................... 8
  SIMPLE SORTING......................................................................................................................................... 8
  CUSTOM SORT ............................................................................................................................................ 8
  FILTERING................................................................................................................................................... 9

TABLES ...................................................................................................................................................... 10
  TABLE FUNCTIONS..................................................................................................................................... 11

SLICERS ..................................................................................................................................................... 12
  MORE ABOUT SLICERS .............................................................................................................................. 14

NUMBER FORMATTING ........................................................................................................................... 14

THEMES ..................................................................................................................................................... 15

SCALING .................................................................................................................................................... 15

SET REPEATING TITLES ............................................................................................................................ 16

INSPECTION OPTIONS ............................................................................................................................. 17

AUTOSUM .................................................................................................................................................. 17

SHORTCUTS .............................................................................................................................................. 18
  FREQUENTLY USED SHORTCUTS................................................................................................................ 18
  FORMATTING SHORTCUTS.......................................................................................................................... 19
  NAVIGATION.............................................................................................................................................. 19

WSU MICROSOFT OFFICE POWER USER PROGRAM ............................................................................. 19
EXCEL NAVIGATION

1. **Title Bar** contains the name of the active application. When the workbook window is maximized, the workbook title appears in the Excel title bar; otherwise, the title appears in a separate title bar within the workbook window.

2. **Ribbon** is a panel that houses the command buttons and icons, organized into a set of tabs.

3. **Quick Access Toolbar** is a toolbar that provides easy access to frequently used commands in the application. It can be customized to fit individual needs.

4. **Name Box** displays the cell reference of the active cell. It also displays the name of the current function when using the formula palette.

5. **Formula Bar** displays the contents of the active cell.

6. **Status Bar** displays details about filtered data and which view is displayed. (Normal, Page Layout, Page Break Preview)

7. **Sheet**: Workbooks can contain multiple sheets.

**Navigation Options**

There are a number of ways to move around in Excel. To move to a specific cell or range (group of cells), use either the mouse or the keyboard.
<table>
<thead>
<tr>
<th>Action</th>
<th>Mouse Techniques</th>
<th>Keyboard Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the active cell one cell at a time</td>
<td>Point and Click at adjacent cell</td>
<td>Use Arrow keys. (Scroll Lock must be off.)</td>
</tr>
<tr>
<td>Move the Worksheet display up or down one</td>
<td>Click on the vertical scroll bar, between the scroll</td>
<td>Use the Page Up or Page Down keys.</td>
</tr>
<tr>
<td>screen at a time</td>
<td>box and the scroll arrow</td>
<td></td>
</tr>
<tr>
<td>Move the Worksheet display to the left or</td>
<td>Click the horizontal scroll bar, between the scroll</td>
<td>Use the ALT+Page Up or ALT+Page Down keys</td>
</tr>
<tr>
<td>right one screen at a time</td>
<td>box and the scroll arrow</td>
<td></td>
</tr>
<tr>
<td>Move the active cell to A1 in the active</td>
<td>Click in the Name text box, type A1 and press Enter</td>
<td>CTRL+Home</td>
</tr>
<tr>
<td>worksheet</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**FLASH FILL**

The Flash Fill command on the data tab is an excellent assistant for spreadsheet completion. Flash Fill evaluates example data, compares it to existing data in adjacent cells, determines any patterns, and suggests entries.

**Recognizing Patterns**

Notice how a clear pattern is established in the example below. There is a column with full name, and a column with a pattern of `firstname.lastname@wichita.edu`

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A</strong></td>
<td><strong>B</strong></td>
<td><strong>C</strong></td>
</tr>
<tr>
<td>1</td>
<td>Full Name</td>
<td>Email</td>
</tr>
<tr>
<td>2</td>
<td>Ali Levine</td>
<td><a href="mailto:ali.levine@wichita.edu">ali.levine@wichita.edu</a></td>
</tr>
<tr>
<td>3</td>
<td>Amy Belden</td>
<td><a href="mailto:amy.belden@wichita.edu">amy.belden@wichita.edu</a></td>
</tr>
<tr>
<td>4</td>
<td>Madelyne Toney</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Marsha Norton</td>
<td></td>
</tr>
</tbody>
</table>

Place the cursor in the next row down, and go to Home tab, Editing group, select the Fill Dropdown and Flash Fill
Excel completes the list with the established pattern. There are so many ways to utilize this tool!

**Flash Fill to Combine Cells**

Another great use of Flash Fill is to combine two cells.

Look at this example of a database, showing three columns of names. Two are complete, first name and last name. One is incomplete, with the beginnings of a pattern established, putting the names together for a full name column.

1. Flash Fill will suggest how to fill the list when it recognizes a pattern.
2. Press Enter to accept the suggestions.

3. Flash Fill also works the other direction: to split a column of “last name, first name” into two columns. It is an excellent time saving tool.
**FIND AND REPLACE**

The Find and Replace dialog box has the capability to find and change formatting, as well as options to search across all sheets in a workbook or to restrict the search and subsequent changes to the current worksheet.

<table>
<thead>
<tr>
<th>Find Option</th>
<th>Used To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find What text box</td>
<td>Specify the text to be located</td>
</tr>
<tr>
<td>Find All button</td>
<td>Locate every instance of the search criteria. It will also populate a list of hyperlinks at the bottom of the Find and Replace dialog.</td>
</tr>
<tr>
<td>Find Next button</td>
<td>Locate the next instance of the search criteria</td>
</tr>
</tbody>
</table>

1. Locate the **Editing Group** on the Home Tab. Click the down-arrow associated with the Find & Select Command.
2. **Find and Replace** dialog can also be opened by pressing CTRL+H to open the Find and Replace dialog box (CTRL+F) will open the Find dialog box, although clicking on the Replace tab will open the Replace options.
3. Click the Options button to expand the search options.

4. Click into the Find what text box and enter in the desired text to search.
5. Click into the Replace with text box and type replacement text.
6. Click the Find Next button and the cursor will jump to the next cell in the next row that contains the search term.
7. Click the **Replace All** button. A message box will display with the number of instances where replacements were made.
SORTING AND FILTERING

At some point after entering a listing of data it will be necessary to reorganize the data. That is where sorting and filtering comes into play.

Simple Sorting

As long as the range of data does not have completely blank columns or rows included in the data, the entire listing will be sorted. However, if there is a blank row or column as part of the list, the list will be “broken” when sorted.

1. Place the cursor in one of the cells of the column to be sorted.
2. Click the Sort & Filter command found in the Editing group.
3. Choose Sort A to Z to sort alphabetically, or filter from the options shown.

Custom Sort

Custom Sorting is used when there are multiple criteria for the sort. For instance, sort the list by Department, Last Name, and First Name.

1. Place the cursor in one of the cells of a column to be sorted.
2. Click the Sort & Filter command found in the Editing group.
3. Choose Custom Sort.
4. In the first Sort By drop down choose the first column to be sorted.
5. If the Sort by drop downs list does not show titles but instead columns, make sure the check mark for “My data has headers” is enabled.
6. Click **Add Level** to add additional criteria
7. When finished adding levels, click **Ok**.

---

**Filtering**

There may be times when a subset of the list is necessary. For instance in our example, a listing of only Executives may be required. Filtering can assist with providing the desired data.

1. Place the cursor in one of the cells of the column to be sorted.
2. Click the **Sort & Filter** command found in the **Editing** group.
3. Choose the **Filter** command.

4. All the headers for the columns now have drop down arrows.
5. Click on a drop-down arrow and select filter criteria.
6. Click **OK**.
7. Only selected records are now displayed.
✓ To clear a filter, click on the dropdown arrow, and select “Clear Filter from [column name]”

**TABLES**

To make managing and analyzing a group of related data easier, you can turn a range of cells into a table.

1. Once a database has been created, select **Format as Table** under the Styles pane in the home tab.
2. Select the desired table style from the dropdown. This can be adjusted later if desired.
3. In the subsequent dialog box, confirm that the correct range of cells is selected. Also indicate here if the table has headers.

![Format As Table dialog box](image)

**Table Functions**

Note that once a table is created, filters appear at the top of each column.

1. Click onto the table until the Table Tools Design tab appears.
2. On the Table Tools Design tab, click the box next to “Total Row” to add a total row at the button of the data.
3. Note that on the newly created Total Row, there are additional formula functions in the dropdown.

4. At any point, the table style can be altered in the Table Tools Design tab under Table Styles.

**SLICERS**

Slicers provide buttons that allow you to easily filter table data. This can be useful in presentations or to allow others a simple way to filter data when sharing documents digitally.

1. Click on the table to activate the Table Tools Design Tab.
2. On the Table Tools Design Tab select **Insert Slicer**.
3. Select the desired data to be filtered. More than one may be selected; this will create multiple slicers.

4. In this case, a slicer was created for the “Department” Tab of a spreadsheet. Click on a category to filter the data in this column with one click of a button.

5. Note that this has created a filter at the top of the column. The filter can be controlled either from the slicer panel or the top of the column (See Sorting and Filtering Section).

6. To clear a slicer, click the “Clear Filter” button at the top right of the slicer.
7. To change the appearance of the slicer, select the slicer until the Slicer Tools tab appears, and select a new style from the Slicer Styles menu.

More About Slicers

✓ Slicer location can be moved with a mouse, much like a picture. To delete the slicer entirely, select the slicer pane and press the delete key.

✓ Note that slicers will print, so remember to delete them before printing, if desired.

✓ Slicers will default to showing data alphabetically. To change the order, create a custom list (see Create Custom List), with the desired list order.

NUMBER FORMATTING

Number formatting is an important setting to understand. Formatting numbers will not interfere with formulas and functions. Number formatting options can be found in the Home tab, Number group. Select the dropdown to see a full range of options:

The last option, More Number Formats, will allow users to create custom number formats, or use Special number formats, like zip code or phone number.
**THEMES**

Selecting a theme in Excel allows for additional customization of color palettes and font sets. To select a theme:

1. Go to **Page Layout** tab, **Themes** group
2. Select a theme from the drop-down menu

Note that this group also allows for customization of **color palettes** and **fonts**.

**SCALING**

When printing a spreadsheet, it is helpful to know about scaling options. Occasionally users will have a spreadsheet that is too wide to fit onto one page, for instance.

1. Go to **File → Print**
2. On the Print menu, the last option says “No Scaling.” Select that dropdown to see full range of options.
3. Note the option to fit the entire sheet onto one page, or the option to fit all columns onto one page.
SET REPEATING TITLES

A repeating title is a specified range of cells that print at the top of every page or at the left of every page. Use repeating titles if the worksheet has multiple pages and adding the column or row titles on every printed page will add clarity to the data.

1. From the Page Layout Tab menu, select the Print Titles button found in the Page Setup Group.

2. The Sheet Tab will be displayed.
3. Click the white space next to the Rows to repeat at top prompt.
4. Select the Row(s) desired to repeat on each page of the printout.
5. Note there is also an option to select the Column(s) desired to repeat on each page of the printout.
INSPECTION OPTIONS

There are three inspection options in Excel (and many Microsoft Office programs). To see these options, Go to File → Check for Issues

Inspect Document: This option is a great general check for a document before publishing. It will check for possible issues like, author information, printer information, picture crop information, headers and footers, and much more.

Check Accessibility: Checking for accessibility is very important. Your audience may be accessing your document with a screen reader, and this check will help ensure that they will be able to access all the various elements.

- Missing Alt Text is a common error. Alt Text is the text that will be read to somebody accessing a document with a screen reader to describe pictures and other elements.
- Remember that for most programs, Alt text may be found in a right click menu (Format Picture, or table properties are a couple examples).

Check Compatibility: This will inspect the document for compatibility across older versions of Excel and tell users possible issues that could arise with newer features (e.g. slicers).

AUTOSUM

While creating formulas manually is a great skill, there are also some shortcuts available in the home tab for some popular simple functions.

1. Select the cell where the formula is to appear.
2. Go to Home Tab → Editing Group → AutoSum
3. Note the drop down options include the ability to quickly calculate the following from data:
   ✓ Sum
   ✓ Average
   ✓ Max
   ✓ Min
   ✓ Count

4. Note the wavy green line that appears after making a selection from the Auto Sum dropdown. Sometimes Excel guesses correctly for the data to calculate, and sometimes the wavy line needs to be corrected.
   ✓ To correct the data source, select the first cell to be included, hold down the mouse and drag to the end of data source.

1. Press **Enter** or **Tab** to accept the formula.

---

**SHORTCUTS**

### Frequently Used Shortcuts

<table>
<thead>
<tr>
<th>Frequently used shortcuts</th>
<th>Key Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close a spreadsheet</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Open a spreadsheet</td>
<td>Ctrl+0</td>
</tr>
<tr>
<td>Go to home tab</td>
<td>Alt+H</td>
</tr>
<tr>
<td>Save a spreadsheet</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Remove cell contents</td>
<td>Delete key</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Go to Page Layout tab</td>
<td>Alt+P</td>
</tr>
<tr>
<td>Go to Data tab</td>
<td>Alt+A</td>
</tr>
<tr>
<td>Go to View tab</td>
<td>Alt+W</td>
</tr>
<tr>
<td>Delete Column</td>
<td>Alt+H, D, then C</td>
</tr>
<tr>
<td>Go to Formula tab</td>
<td>Alt+M</td>
</tr>
<tr>
<td>Hide selected rows</td>
<td>Ctrl+9</td>
</tr>
<tr>
<td>Hide selected columns</td>
<td>Ctrl+0</td>
</tr>
<tr>
<td>Create table</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Check spelling</td>
<td>F7</td>
</tr>
</tbody>
</table>
**Frequently used shortcuts**

<table>
<thead>
<tr>
<th>Formatting</th>
<th>Key Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Time</td>
<td>Ctrl+Shift+colon (:)</td>
</tr>
<tr>
<td>Current Date</td>
<td>Ctrl+Shift+semicolon (;)</td>
</tr>
</tbody>
</table>

**Formatting Shortcuts**

<table>
<thead>
<tr>
<th>Formatting</th>
<th>Key Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Italicize text</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Bold text</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Underline Text</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Strikethrough</td>
<td>Ctrl+5</td>
</tr>
<tr>
<td>Outline border</td>
<td>Ctrl+Shift+7</td>
</tr>
<tr>
<td>General number format</td>
<td>Ctrl+Shift+~</td>
</tr>
<tr>
<td>Currency number format</td>
<td>Ctrl+Shift+4</td>
</tr>
<tr>
<td>Choose a fill color</td>
<td>Alt+H,H</td>
</tr>
<tr>
<td>Center align cell contents</td>
<td>Alt+H,A,then C</td>
</tr>
<tr>
<td>Add borders</td>
<td>Alt+H,B</td>
</tr>
</tbody>
</table>

**Navigation**

<table>
<thead>
<tr>
<th>Navigation</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up one cell</td>
<td>Up arrow key</td>
</tr>
<tr>
<td>Down one cell</td>
<td>Down arrow key</td>
</tr>
<tr>
<td>Left one cell</td>
<td>Left arrow key</td>
</tr>
<tr>
<td>Right one cell</td>
<td>Right arrow key OR Tab</td>
</tr>
<tr>
<td>Edge of current data</td>
<td>Ctrl+arrow key</td>
</tr>
<tr>
<td>Last cell in worksheet</td>
<td>Ctrl+End</td>
</tr>
<tr>
<td>Extend selection to last cell</td>
<td>Ctrl+Shift+End</td>
</tr>
<tr>
<td>First cell of a worksheet</td>
<td>Ctrl+Home</td>
</tr>
<tr>
<td>Previous sheet in a workbook</td>
<td>Ctrl+Page Up</td>
</tr>
</tbody>
</table>

**WSU MICROSOFT OFFICE POWER USER PROGRAM**

Become a Power User! Attend a full suite of Microsoft Office trainings from ITS and receive a Power User Certificate. For more information, visit: wichita.edu/poweruser