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PIVOT TABLE FUNDAMENTALS 

What is a Pivot Table 

A Pivot Table is a powerful tool that allows you to summarize, organize and interact with a large 
set of data.  

When to Use a Pivot Table 

A pivot table is an excellent tool for a variety of uses: 

• Analyzing and summarizing a large amount of data 
• Finding relationships with the data 
• Creating a list of unique values for a single field in the data 
• Finding data trends 
• Organizing data 
• Quickly finding subtotals based on different groupings of data. 

The Anatomy of a Pivot Table 

A pivot table is composed of four areas. The data placed in these areas defines both the utility 
and appearance of the pivot table. 

Values Area: The heart of the pivot table. This area typically includes a total of one or more 
numeric fields. It is also possible to have the same field dropped into the values area more than 
once with different calculations such as a Sum and an Average. 

Columns Area: The columns area is composed of headings that stretch across the top of 
columns in a pivot table. The columns area is ideal to show trending over time. 

Rows Area: The rows area is composed of headings that go down the left side of the pivot 
table. Dropping a field into the rows area displays unique values. The rows area typically has at 
least one field, although it is possible to have no fields. 

Filters Area: This area is an optional area which can be used to filter data items dynamically. A 
filters area can have more than one drop-down. 

Proper Preparation of Data 

It is important to prepare the data source for the pivot table report so that the first row of the 
data contains the field names or column names which describe the data in each column. 

 Do not include blank rows or columns. Excel assumes you want to end a range of data 
when you use blank rows. 

 Limit the number of columns to separate sets of data. 
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Example of Improper Data Format – Repeating Groups: 

 
 Avoid storing data in section headings. Excel will not be able to convert the data into a 

usable pivot table. 

Improperly Formatted Data using Section Groups: 

 
To Summarize: 

• The first row of the data source consists of field labels or headings that describe the 
information in each column 

• Each column in the data source represents a unique category of data 
• Each row in the data source represents individual items in each column 
• None of the column names in the data source doubles as data items that will be used as 

filters or query criteria. I.e. names of months, names of locations, or names of 
employees) 

 

Creating a PivotTable 

1. Open your workbook to the sheet with your 
data. 

2. From the Insert tab, select PivotTable. 
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3. A dialog box appears querying what data to include and where to put the pivot table
report. Click OK, and a new sheet is created with the Pivot Table.

4. A PivotTable Fields pane on the right side of the screen displays an outline of the
PivotTable in the body of the worksheet.

5. Drag fields from the Choose Fields section of the PivotTable Fields pane down to the
squares that appear below: Filters, Rows, Columns and Values. The Values field is for
the figures that are to be calculated.

Creating a Pivot Table from a Table 

 It is possible to create a Pivot Table from a Table. This is particularly advantageous if the 
source data will be changing, as you will not need to update the source data every time the pivot 
table is updated (see troubleshooting). 

To create a Pivot Table from a Table: 

1. Format your data as a table.
2. Go to Table Tools, select Summarize with Pivot Table.
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3. Follow the same prompts as listed above. 

 

WORKING WITH PIVOT TABLES 

Updates to Pivot Tables 

If any changes are made to the source data, remember to refresh the pivot table.   

To refresh the pivot table: 

1. Go to Pivot Table Tools, Analyze Tab, Data Group. 
2. Click Refresh button. 

OR 
1. Right click over the pivot table 
2. Select Refresh. 

 

Changing Data Source 

If new lines are added to the pivot table, or if unknown errors occur with the pivot table, the Data 
Source may need to be updated. 

 To update the data source for the pivot table: 

1. Go to Pivot Table Tools, Analyze Tab, Data Group 

2. Click Change Data Source 

3. Select the entire data in the source data sheet. 
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Calculated Fields 

Sometimes you would like to create a calculation with figures inside your PivotTable. To create 
a Calculated Field: 

1. Select the PivotTable and select the PivotTable tools Analyze contextual tab. 
2. In the Calculations group, select Fields, Items, and Sets. 
3. Select Calculated Field.  

 

4. A dialog box will open. Create a Name for the field. 
5. Double click on a field to bring it in to the formula. An example is below, subtracting 

Expense from Revenue to arrive at Net Income. 

 

Pivot Table Design Options 

Notice that when the Pivot Table is selected, a couple of 
contextual tabs appear in the ribbon: Analyze and Design 
tabs. We have already discussed many parts of the Analyze 
Tab. Let’s dive into the Design Tab. 
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The Design tab contains 

• Layout Options: Select whether to show or hide subtotals and grand totals and select 
form a variety of layouts. 

• Pivot Table Style Options: Decide where to show headers (recommended) or if you 
would like banded rows 

• Pivot Table Styles: Select from a variety of looks incorporating the color pallet you 
selected. 
 

 

Using Slicers 

Slicers enable the filtering of pivot tables similarly to filters. The difference is that slicers offer a 
user-friendly interface that enables the ability to see what filters have been applied. 

Creating a Standard Slicer 
1. Place the cursor inside a pivot table 
2. Select the Insert tab on the ribbon 
3. Click the Slicer command 
4. Select the dimensions to use in the slicer 

 
 Hold down the CTRL key while selecting multiple values 

Creating a Timeline Slicer 
The timeline slicer works in the same way as a standard slicer. The difference is that the 
timeline slicer is designed to work exclusively with date fields. 

1. Place the cursor inside a pivot table 
2. Select the Insert tab on the ribbon 
3. Click the Timeline command 
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4. Select a date field (Week Ending) 
5. Change the timeline configuration to the desired format 

 
 

CREATING AND MODIFYING CHARTS 

Create a Chart  
Pictures or Graphs are a way to highlight key numbers and values in comparison to each other. 

 
1. Select the data to graph. Include labels and descriptions 
2. Either go to Insert tab and select a Chart or Recommended Chart, or Press F11 to 

create a recommended chart on a separate page 
Modify Chart Items  
The custom Ribbon called Chart Tools displays when a selecting a chart. The Chart Tools 
Design tab enables color changes, as well as chart layouts. The Chart Tools Layout tab 
provides commands to change the configuration of the chart while the Chart Tools Format tab is 
used further format the chart with custom elements. 

• Chart Area: the entire chart and all its elements 
• Plot Area: the area bounded by the axes 
• Axis: a line bordering the chart plot area used as a frame of reference for the 

measurement 
• Title: descriptive text that is automatically aligned to an axis or centered at the top of a 

chart 
• Data Labels: text that provides additional information about a data marker which 

represents a sing data point or value that originates from a worksheet 
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• Legend: a box that identifies the patterns or colors that are assigned to the data series or 
categories in a chart 

 
1. Select the object to be changed (Legend) 
2. Select the Format tab 
3. Select the command Format Selection 
4. Repeat as necessary to other objects in the chart 

Chart Elements 
In the upper right of the chart, click on the plus sign to access Chart Elements.  
Here you can select or remove the visibility of: 

  

• Axes 
• Axis Titles 
• Chart Title 
• Data Labels 
• Data Table 
• Error Bars 
• Gridlines 
• Legend 
• Trendline 
Note: available chart elements will vary depending on which chart is 
chosen. 
 
 

Style/Color 
Click on the paint brush in the upper right of the chart.  Here you can 
modify the style and color of the chart. 

 
Be mindful that you should never use color alone to convey meaning 
with a chart. Be sure that there are also numbers visible for those who 
have difficulty differentiating between colors. Consider adjusting the 
gradient level as well to further assist in differentiating. 
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Filter 
Click on the Filter button in the upper right of the chart.  Here you can quickly isolate specific 
variables. 

 

Add a Trendline 
It is possible to add a trendline or moving average to any data series in an unstacked, 2-D, area, 
bar, column, line, stock, xy (scatter), or bubble chart. A trendline is always associated with a 
data series, but a trendline does not represent the data of that data series. Instead, a trendline 
is used to depict trends in the existing data or forecasts of future data. 

Linear trendlines: A linear trendline is a best-fit straight line that is used with simple linear data 
sets. The data is linear if the pattern in its data points resembles a line. A linear trendline usually 
shows that something is increasing or decreasing at a steady rate. 

Logarithmic trendlines: A logarithmic trendline is a best-fit curved line that is used when the 
rate of change in the data increases or decreases quickly and then levels out. A logarithmic 
trendline can use both negative and positive values. 

Polynomial trendlines: A polynomial trendline is a curved line that is used when data 
fluctuates. It is useful, for example, for analyzing gains and losses over a large data set. The 
order of the polynomial can be determined by the number of fluctuations in the data or by how 
many bends (hills and valleys) appear in the curve. An Order 2 polynomial trendline generally 
has only one hill or valley. Order 3 generally has one or two hills or valleys. Order 4 generally 
has up to three hills or valleys. 

Power trendlines: A power trendline is a curved line that is used with data sets that compare 
measurements that increase at a specific rate — for example, the acceleration of a race car at 
1-second intervals. It is not possible to create a power trendline if the data contains zero or 
negative values. 

Exponential trendlines: An exponential trendline is a curved line that is used when data values 
rise or fall at constantly increasing rates. It is not possible to create an exponential trendline if 
the data contains zero or negative values. 
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Moving average trendlines: A moving average trendline 
smoothes out fluctuations in data to show a pattern or trend 
more clearly. A moving average uses a specific number of 
data points (set by the Period option), averages them, and 
uses the average value as a point in the line. For example, if 
Period is set to 2, the average of the first two data points is 
used as the first point in the moving average trendline. The 
average of the second and third data points is used as the 
second point in the trendline, etc. 

 

To access Trendline options:  

1. Select the Chart. 
2. On the Chart Tools Layout tab select Add Chart 
Element. 
3. Choose the desired trendline. 
4. If necessary, select the data series for the desired 
trendline. 

 

MAPPING GEOGRAPHIC DATA 
This is just the beginning of features to come in Excel as Microsoft continues with their AI vision. 
This feature requires Excel 2016 or later, and a connection to the internet. 

 

Make sure the source data is a vertically oriented list with locations in one column, and any 
important categories and/or dates in another. If dates are going to be used, be sure the column 
is formatted as a date number formatting. 

 

1. Place the cursor inside the data (don’t preselect all data) 
2. Go to the Insert tab, in the Tours group select 3D Map 

 
 If prompted, press Enable in the popup screen to activate this feature. This will give 

Excel permission to access the internet for maps. 
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3. Try inserting pertinent categories into the Categories field, much like a Pivot table. If 
times and dates were used, those can be inserted into Time. 
 

If time is used, a play button will appear at the bottom of the screen. This will create a video 
timeline using the geographic data. 

 

 

In the ribbon, note the ability to create and export a video or take a screen shot of the map for 
use in PowerPoint or other projects.  

 

 

 

When closing out of the map view, this map data will be saved with the Excel workbook and will 
be accessible for later use by going to the Insert tab and selecting 3D Map. 
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WSU MICROSOFT OFFICE POWER USER PROGRAM 
Become a Power User!  Attend a full suite of Microsoft Office trainings from ITS and receive a 
Power User Certificate. For more information, visit: wichita.edu/poweruser 

 

 

 

QUESTIONS? 

Contact information 

Password Assistance: 

• Technology Help Desk:  (316) 978-HELP or helpdesk@wichita.edu 
 

Assistance: 

• ITS Applications Training:  (316) 978-5800 or training@wichita.edu 

mailto:helpdesk@wichita.edu
mailto:training@wichita.edu
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